Answer ( 1 )

  1. This answer is edited.

    Hi Chandra,

    Thank you for the question. The problem here is because APPSeCONNECT agent creates a Web Server within the environment where on premise agent is installed to process incoming http requests.

    From your error message it is evident that you have Wamp installed in the machine and it conflicts with the Web Server which Agent is creating. The solution is either you disable the Wamp server and then start the Agent or else use separate ports (not from valid http port range) which are not registered in the Wamp server.

    To Disable WAMP from starting follow the steps :

    1. Open Run using Windows + R key.
    2. Type ‘services.msc’ and click ok.
    3. Find the service ‘wampcache’ or wampcache64 from the list of services.
    4. Right click and open properties.
    5. Stop the service and make the service to manual.

    Now after you reboot the system, the system will clear all ports which it acquired during startup. Now run the agent, and Login. Notice, it should not show an error message while start up.

    If you do not want to disable WAMP, follow the steps:

    1. Open portal.appseconnect.com.
    2. Go to APIs.
    3. Register your url for proxy.
    4. Your subdomain will be created and you can use it configure the touchpoints. The subdomain will look like ‘xxx.appseconnectapi.com’
    5. Now open the touchpoint you want to call, the URL should be changed to use your subdomain.

    The above step will create a proxy and allow you to call the Same URLs in Https.

    Let me know if this helps.

    Best answer

Leave an answer

Please Log in to answer to this question .